MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Possible Bug in ArcTan ?

  • To: mathgroup at
  • Subject: [mg64770] Possible Bug in ArcTan ?
  • From: "JCDenton" <post4uw at>
  • Date: Thu, 2 Mar 2006 06:48:45 -0500 (EST)
  • Sender: owner-wri-mathgroup at

Hi Group!

I am describing resonant electrical systems with Mathematica. So there
is a lot of dealing with complex numbers and functions. One important
function is:


This function is zero when Im = 0. The problem is, that when I plot
this function it shows some strange behaviour near this zero point. It
looks somehow, as if the function values are multiplied with -1 or
something like that. I also tried to calculate a table an plot this
with gnuplot where the stepsize was 0.005. I was the same strange
situation. So I am sure it is not the Plot function that is buggy but
the ArcTan itself. I also tried the table with step size 0.05 and I get
the "right" picture with gnuplot. Is this a known bug? I have not found
something about it yet.

I realy need this function, since it is a very important operation in
complex calculation.

Thank you!

  • Prev by Date: Re: Lists of all values of a two-variable function
  • Next by Date: Ploting a changing constant
  • Previous by thread: Re: Help: running external program on Mac OS X
  • Next by thread: Re: Possible Bug in ArcTan ?