Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1995
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1995

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: mma graphics

  • To: mathgroup at christensen.cybernetics.net
  • Subject: [mg1276] Re: [mg1217] mma graphics
  • From: hannibal at caesar.physik.uni-oldenburg.de (Ludger Hannibal)
  • Date: Wed, 31 May 1995 03:45:42 -0400

> 
> When I generate .eps files using mathematica and include it in a LaTeX
> document it always appears on a separate page with the legend. This happens
> irrespective of how small I make the picture. I do not face this problem with
> .eps files coming from other sources like gnuplot. At least three of us in this
> department face the problem and none of us know the answer.
> 
> This is what I do and I would appreciate any help with spotting any mistake I
> am making
> 
> Out[]:= -Graphics-
> In[] := Display["filename.raw",%]
> 
> % psfix -epsf filename.raw > filename.eps
> 
> In my LaTeX document: 
> \begin{figure}
> \epsfxsize=4.0in\epsffile{filename.eps}
> \caption[cc]{cc}\label{'c'}
> \end{figure}
> 
> Abbey Perumpanani,
> Mathematical Institute,
> 24 - 29 St Giles', Oxford,
> England.
> 
> 
> 
1) I had also some problem with epsf-files: On IBM/RISC 6000 the bounding box
included is wrong, if you clip the picture to the boundings given,
you get only some enlarged portion of the picture. (The epsf file
made problems when using xfig or ghostview; xfig is a nice tool for
labeling mathematica graphs with anything, even LaTeX formatted in combination
with transfig). 

My workaround for this : replace the wrong  138 138 in
the %%bounding box line by 288 288

a version for Unix: (uses line editor sed for search and replace)


EPSWrite[graph_, file_String]:=
(Display[StringJoin["!rasterps -format eps |
 sed \"s/138 138/288 288/\" > ",file],graph];graph)

2) If this is not relevant for you, try giving the \begin{figure}
explicit  options [htb] etc. This worked in one case where I had 
the same problem.

Yours, Ludger


  • Prev by Date: Re: Re: Problems with ImplicitPlot
  • Next by Date: Re: Which of Maeder's Mma Programming Books?
  • Previous by thread: mma graphics
  • Next by thread: Thanks from Blind User