Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2002
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2002

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Sovling integrals: non-algebraic???

  • To: mathgroup at smc.vnet.net
  • Subject: [mg35376] Re: [mg35369] Sovling integrals: non-algebraic???
  • From: Andrzej Kozlowski <andrzej at platon.c.u-tokyo.ac.jp>
  • Date: Wed, 10 Jul 2002 02:19:42 -0400 (EDT)
  • Sender: owner-wri-mathgroup at wolfram.com

Your equation is:

In[6]:=
Integrate[(c x^d), {x, a, b}] ==y

Out[6]=
c*(-(a^(1 + d)/(1 + d)) + b^(1 + d)/(1 + d)) == y

Solve cannot solve this because it is not meant to. Solve can only solve 
equations which are "essentially algebraic", which means basically all 
for which they are general non-numerical methods.

Your other attempt using SolveAlways is just a case of complete 
misunderstanding of what this function does. SolveAlways is for 
"identities". For example:
In[12]:=
SolveAlways[d + x == d, d]

means find x such that for all d, d + x == x, so of course the answer is

Out[12]=
{{x -> 0}}

Your equation

SolveAlways[c*(-(a^(1 + d)/(1 + d)) + b^(1 + d)/(1 + d)) == y,d]

is saying: find c,a, b and y such that for all d the above relation 
holds. In fact the relation cannot hold for all d  whatever the values 
of the variables, but in any case this clearly has nothing to do with 
what you were trying to do.

In fact your equation can't be "solved" if by solving you mean 
expressing a "general solution" in terms of some known functions of the 
parameters. It is indeed, as you wrote, "mathematically impossible".

Andrzej Kozlowski
Toyama International University
JAPAN
http://platon.c.u-tokyo.ac.jp/andrzej/

On Tuesday, July 9, 2002, at 07:51  PM, Björn wrote:

> Hello!
>
> I can't make Mathematica solve an expression for a variable which is
> inside an integral. Integrals are of the form:
> Integrate[f, {x, xmin, xmax}]
>
> And my expression is of the kind:
> Solve[Integrate[(c x^d), {x, a, b}] == y, d]
>
> Now, Mathematica can solve for a, b and c. But it cannot solve for d.
> Why?
>
> It gives me the message:
> "The equations appear to involve the variables to be solved for in an
> essentially non-algebraic way."
>
> If I try SolveAlways[Integrate[c x^d, {x, a, b}] == y, d],
> I get the message:
> "The expression (a^(1 + d)) involves unknowns in more than one
> argument, so inverse functions cannot be used."
>
> (It isn't mathematically impossible, right?)
>
> Most thankful for any help!
>
>
>



  • Prev by Date: Re: cross product
  • Next by Date: Re: Strategy for overly long computations?
  • Previous by thread: RE: Sovling integrals: non-algebraic???
  • Next by thread: Re: Sovling integrals: non-algebraic???