Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2004
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2004

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Another Combinatorica loading problem

  • To: mathgroup at smc.vnet.net
  • Subject: [mg50137] Re: Another Combinatorica loading problem
  • From: "Dr. Wolfgang Hintze" <weh at snafu.de>
  • Date: Tue, 17 Aug 2004 05:01:09 -0400 (EDT)
  • References: <cfkaj9$fa0$1@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Steve,

Using Mathematica 4.0 I put NewCombinatorica.m in the same path as you 
did, viz.

D:\ProgramFiles\WolframResearch\Mathematica\5.0\AddOns\StandardPackages\DiscreteMath

and let Combinatorica.m (old) there as was.

Then, interestingly, I noticed different behaviour of Needs[] and Get[].

First trying

In[1]:=
Needs["DiscreteMath`NewCombinatorica`"];

produced the error messages

 From In[1]:=
Needs::"nocont" : "Context \!\(\"DiscreteMath`NewCombinatorica`\"\) was 
not \
created when Needs was evaluated."

but nevertheless worked correctly.

Quitting the local kernel (or restarting Mathematica) and doing

In[2]:=
<< "DiscreteMath`NewCombinatorica`"

worked from the start without any error message.

BTW: I took ?RandomGraph as an indication of the package version.

Wolfgang


Steve Gray wrote:

> My Combinatorica.m is in
> 
> D:\ProgramFiles\WolframResearch\Mathematica\5.0\AddOns\StandardPackages\DiscreteMath
> 
> but neither
> << DiscreteMath`Combinatorica`
> nor
> Needs["DiscreteMath`Combinatorica`"];
> 
> apparently loads it because NthPermutation[100,{a,b,c,d,e,f,g}] just echoes NthPermutation.
> My $Path is
> 
> { D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\JLink, 
>   D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\NETLink,
>   D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\StandardPackages\StartUp,   
>   D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\StandardPackages\StartUp,
>   D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\Autoload,
>   D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\Applications,
>   D:\Program Files\Wolfram Research\Mathematica\5.0\AddOns\ExtraPackages,
>   D:\Program Files\Wolfram Research\Mathematica\5.0\SystemFiles\Graphics\Packages,
>   D:\Program Files\Wolfram Research\Mathematica\5.0\Configuration\Kernel  }
> (plus some other stuff)
> 
>    How do I put the required path into $Path, and I wonder why wasn't it included in the package I
> received? I changed nothing about Path.
>    Thanks for any info. This will be holding me up.
> 
> Steve Gray
> 
> 


  • Prev by Date: Re: Simplify, FullSimplify, .....
  • Next by Date: can this be solved in Mathematica 5.0?
  • Previous by thread: Re: Another Combinatorica loading problem
  • Next by thread: Re: New user: Absproblem