Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: J/Link problem on Mac OS X

  • To: mathgroup at smc.vnet.net
  • Subject: [mg55239] Re: [mg55204] J/Link problem on Mac OS X
  • From: Todd Gayley <tgayley at wolfram.com>
  • Date: Thu, 17 Mar 2005 03:29:49 -0500 (EST)
  • Sender: owner-wri-mathgroup at wolfram.com

At 04:36 AM 3/16/2005, Mike wrote:
>I've recently become aware that I cannot run J/link programs on my computer
>when using version 5.1 (OS X 10.3.8). I had yet to delete version 5.0 and
>that version seems to run all the examples in the J/Link help browser and
>GUI kit fine. Version 5.1 stalls (error messages) at the InstallJava[]
>stage.
>
>Has anyone else experienced this?
>
>Mike


Mike,

This problem is caused by a bug in OS/X 10.3.8. Apple tells us that they 
have fixed the behavior in the upcoming 10.3.9 release. The symptom that 
J/Link users will see is that InstallJava[] will hang depending on certain 
details of their networking configuration.

In the meantime, download J/Link 3.0.2 from 
http://www.wolfram.com/solutions/mathlink/jlink, which incorporates a 
workaround for the problem. The 3.0.2 version of J/Link is identical to the 
3.0.1 version that ships with Mathematica 5.1.1, except for this one fix 
for OS/X 10.3.8.


Todd Gayley
Wolfram Research 


  • Prev by Date: Re: GridLines
  • Next by Date: Re: a simplification problem
  • Previous by thread: Re: using mathematica over the internet
  • Next by thread: Re: J/Link problem on Mac OS X