Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Mathematica won't run if LANG var is set to pt_BR

  • To: mathgroup at smc.vnet.net
  • Subject: [mg60269] Re: Mathematica won't run if LANG var is set to pt_BR
  • From: Jie Li <jli24 at emory.edu>
  • Date: Fri, 9 Sep 2005 04:07:09 -0400 (EDT)
  • Organization: Emory University
  • References: <dfm7v8$hcn$1@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Renan <renan.birck at gmail.com> writes:

> Hello,
>
> I have installed Mathematica in Linux (Ubuntu Linux 5.04 - essentially
> Debian) and works OK, as long as my LANG environment variable is set to 'C'
> (which means 'no specific language') or 'US'.
>
> But I want to use the GNOME window manager in Portuguese, and this,
> "automagically" sets the LANG variable to pt_BR (which means 'Brazilian
> Portuguese'). When this is set, Mathematica will not run, it will error at
> startup with "An illegal right-hand side value was specified for the cell
> style option "FontColor"".
>
> Anybody knows how to fix this problem?
>
> I use Mathematica 5.0.
>
> Thanks,
> Renan




Dear Renan,

Probabaly you can make your own script like this, and name
it mathematica and put it in ~/bin :

#!/bin/sh
export LANG=C
/path/to/your/mathematica


Hope this helps,
Jie


  • Prev by Date: Switching to Mac caused 20x slowdown - please help!
  • Next by Date: cannot find the required native library named JLinkNativeLibrary
  • Previous by thread: Re: Mathematica won't run if LANG var is set to pt_BR
  • Next by thread: Re: Mathematica won't run if LANG var is set to pt_BR