Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

JLink : JavaNew Failure

  • To: mathgroup at smc.vnet.net
  • Subject: [mg66250] JLink : JavaNew Failure
  • From: karenechu at gmail.com
  • Date: Fri, 5 May 2006 05:03:13 -0400 (EDT)
  • Sender: owner-wri-mathgroup at wolfram.com

Hello, everyone,

I am very new to J/Link but I  have been fiddling with it for a while
but I just don't see what was wrong:

I wrote a hello world program in Java and compiled it and put it in a
folder. Then I tried to call it from Mathematica using:

Needs["JLink`"];
InstallJava[CommandLine->"home/usr/java/bin/java"];
AddToClassPath["home/myclasses"];
LoadJavaClass["test"];

All these go well with the new class path added and
JavaClass["test",9] as output to the last line, but when:

test1= JavaNew["test"];

Mathematica failed to created object because " there is no constructor
that takes zero arguments"   even though I put in an explicit
constructor that takes no argument.

I tried putting in a constructor taking an int as an argument and using

test1= JavaNew["test",1]; (after reinstalling Java etc)

but now the type of the argument is wrong.

I think the class is either not properly loaded or something, but I
just dont' know what is wrong!!
Please help!

Thanks a lot, 
cheers,
Kay


  • Prev by Date: Re: How to find expected value?
  • Next by Date: Re: Testing for squares
  • Previous by thread: Re: Mathematica 4.1 on ThinkPAD T40 - Exception ntdll.dll - any advice on how to fix?
  • Next by thread: Re: JLink : JavaNew Failure