MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Memory issue in SVD

  • To: mathgroup at
  • Subject: [mg75026] Re: Memory issue in SVD
  • From: "Raj" <rajanikanth at>
  • Date: Sat, 14 Apr 2007 01:13:49 -0400 (EDT)
  • References: <evn875$qs$>


For Multi-core support, you need to set the OMP_NUM_THREADS variable

For further information, see this thread :



>>To use multiple threads and take advantage of multiple
>> processors or cores, you will need to set OMP_NUM_THREADS to a
>> value of
>> % NUMBER_OF_PROCESSORS% in your environment. You can do this by
>> going to
>> My Computer and get to the properties template by right clicking and
>> clicking Properties, click the Advanced Tab and then click on
>> Environment Variables. Click on New right below the System Variables
>> list. In the the variable name type in OMP_NUM_THREADS and variable
>> value type in % NUMBER_OF_PROCESSORS%
>> ----------------------------------------
>> Variable Name : OMP_NUM_THREADS
>> Variable Value: % NUMBER_OF_PROCESSORS%
>> ----------------------------------------

On Apr 12, 11:33 pm, Tulga Ersal <ter... at> wrote:
> Dear group,
> I apologize in advance to bother you with a topic that came up many
> times in the past, but nothing I found in the archives really helped.
> I am trying to find the singular value decomposition (SVD) of a big
> matrix, but Mathematica gives the following message:
> "No more memory available.
> Mathematica kernel has shut down.
> Try quitting other applications and then retry."
> As an example, create a 5000x5000 matrix with random entries and try
> to find its SVD:
> M=Table[Random[],{5000},{5000}];
> {U,S,V}=SingularValueDecomposition[M];
> My computer cannot perform the SVD and gives the message above almost
> immediately. Originally I thought the matrix was too big and my
> computer didn't really have the necessary resources, but I can
> compute the SVD using another program, so I know it is not really an
> hardware issue. I'm using Mathematica 5.2 on a PC running Windows XP,
> with 2GB RAM, 160GB hard disk, two 3.4 GHz processors.
> Is there a setting in Mathematica that needs tweaking to avoid the
> memory problem? I have tried setting $HistoryLength=0, or using
> Share, and neither helped. I'd appreciate any recommendations.
> Thank you,
> Tulga

  • Prev by Date: Re: area under a parametric curve
  • Next by Date: our good (?!) friend RootSum
  • Previous by thread: Re: Memory issue in SVD
  • Next by thread: more in Assumptions