Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Remote Kernel does nothing

  • To: mathgroup at smc.vnet.net
  • Subject: [mg73075] Re: [mg73026] Remote Kernel does nothing
  • From: Arturas Acus <acus at itpa.lt>
  • Date: Thu, 1 Feb 2007 03:31:07 -0500 (EST)
  • References: <200701301124.GAA12853@smc.vnet.net>

Dear Christop,

My configuration, which I used a year ago for linux to linux box was

In advanced options 

Arguments to MLOpen

-LinkMode Listen -LinkProtocol TCP -LinkOptions MLDontInteract -LinkName
"3500" -LinkHost 193.219.x.x(remote host IP)

string to launch kernel :

ssh user at 193.219.x.x "math" -mathlink -LinkMode Connect -LinkProtocol
TCP -LinkName "3500" -LinkHost 193.219.y.y (local host IP)


You should configure that ssh client should connect without entering
password . (generate private public keys )

However instead of connecting remote kernel I would suggest You to make
computations on remote machine using vnc server. That is simply run on
remote machine xvnc server (I use tightvnc, but there are a lot of
other) then on local host run vnc client to connect vnc server.

This way is better, because You can completely turn off your local
computer not affecting remote computations.



> Hello!
> 
> I have set up a remote Kernel on a Unix machine, the front end is on a windows
> machine using the following options in the Kernel configurations menu:
> 
> plink lhotka@remoteip /usr/local/bin/math -mathlink -LinkMode Connect
> -LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost `hostip`
> 
> I have tried various different commandline options (from The FAQ, PCT, Network
> Programming with Mathematica, etc...)
> 
> This version starts a kernel on the remote machine (without a password prompt)
> - I see it starting up on the remote machine using top -u lhotka, but it does
> nothing.
> 
> The situation is as follows: I In the frontend (on the host) I enter some
> input, the frontend starts a Kernel on the remote machine, nothing comes back.
> Any time I enter some input another Kernel is started, but nothing returns.
> 
> Can somebody please explain me - as detailed as possible - what I should do, I
> have no idea to find out. For sure there is no easy way to establish a
> conection between a Frontend and a Kernel over the network, promised by
> Wolfram Research.
> 
> Thanks in advance,
> 
> Christoph 
-- 
Arturas Acus <acus at itpa.lt>


  • Prev by Date: Re: & without #
  • Next by Date: Re: sort and positon matrix element help
  • Previous by thread: Re: Limit question
  • Next by thread: Re: Re: Remote Kernel does nothing