Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Remote Kernel does nothing

  • To: mathgroup at smc.vnet.net
  • Subject: [mg73110] Re: [mg73075] Re: [mg73026] Remote Kernel does nothing
  • From: "T.Sariyski" <tsariysk at craft-tech.com>
  • Date: Sat, 3 Feb 2007 04:48:21 -0500 (EST)
  • References: <200701301124.GAA12853@smc.vnet.net> <200702010831.DAA10807@smc.vnet.net>

I still get an obscure "Low-level MathLink error: The linkname was missing or not in the proper form." error when try to connect to a remote kernel (client is WinXP/i386, server is SuSe10.1/x86_64, same LAN, no firewalls, no passwords).

Arguments to MLOpen

-LinkMode Listen -LinkProtocol TCPIP -LinkOptions MLDontInteract   
-LinkName "3500"  -LinkHost 192.168.187.99

string to launch kernel :

ssh  tsariysk at 192.168.187.99  '"math" -mathlink -LinkMode Connect 
-LinkProtocol TCP -LinkName "3500"  -LinkHost 192.168.187.99'

ERR:

Mathematica could not establish a connection to the kernel.
Kernel: craft99.
Low-level MathLink error: The linkname was missing or not in the proper 
form.

I tried \"3500\", 3500, \\"3500\\" - the same error. I don't know if 
3500 is a port number or just a tag, I wasn't able to find  any 
documentation about what is LinkName and what are the proper values for 
it. Could somebody post it's current working configuration for remote 
kernel, please?
Thanks, Ted

P.S. Executed from a shell:

ssh  tsariysk at 192.168.187.99  '"math" -mathlink -LinkMode Connect 
-LinkProtocol TCP -LinkName "3500"  -LinkHost 192.168.187.99'

starts a Kernel on the remote machine.


Arturas Acus wrote:
> Dear Christop,
>
> My configuration, which I used a year ago for linux to linux box was
>
> In advanced options 
>
> Arguments to MLOpen
>
> -LinkMode Listen -LinkProtocol TCP -LinkOptions MLDontInteract -LinkName
> "3500" -LinkHost 193.219.x.x(remote host IP)
>
> string to launch kernel :
>
> ssh user at 193.219.x.x "math" -mathlink -LinkMode Connect -LinkProtocol
> TCP -LinkName "3500" -LinkHost 193.219.y.y (local host IP)
>
>
> You should configure that ssh client should connect without entering
> password . (generate private public keys )
>
> However instead of connecting remote kernel I would suggest You to make
> computations on remote machine using vnc server. That is simply run on
> remote machine xvnc server (I use tightvnc, but there are a lot of
> other) then on local host run vnc client to connect vnc server.
>
> This way is better, because You can completely turn off your local
> computer not affecting remote computations.
>
>
>
>   
>> Hello!
>>
>> I have set up a remote Kernel on a Unix machine, the front end is on a windows
>> machine using the following options in the Kernel configurations menu:
>>
>> plink lhotka@remoteip /usr/local/bin/math -mathlink -LinkMode Connect
>> -LinkProtocol TCPIP -LinkName "`linkname`" -LinkHost `hostip`
>>
>> I have tried various different commandline options (from The FAQ, PCT, Network
>> Programming with Mathematica, etc...)
>>
>> This version starts a kernel on the remote machine (without a password prompt)
>> - I see it starting up on the remote machine using top -u lhotka, but it does
>> nothing.
>>
>> The situation is as follows: I In the frontend (on the host) I enter some
>> input, the frontend starts a Kernel on the remote machine, nothing comes back.
>> Any time I enter some input another Kernel is started, but nothing returns.
>>
>> Can somebody please explain me - as detailed as possible - what I should do, I
>> have no idea to find out. For sure there is no easy way to establish a
>> conection between a Frontend and a Kernel over the network, promised by
>> Wolfram Research.
>>
>> Thanks in advance,
>>
>> Christoph 
>>     


-- 
Ted Sariyski
------------
Combustion Research and Flow Technology, Inc.
6210 Keller's Church Road
Pipersville, PA 18947
Tel: 215-766-1520
Fax: 215-766-1524
www.craft-tech.com
tsariysk at craft-tech.com





  • Prev by Date: Re: reverse polish notation
  • Next by Date: Text Function with Graphic
  • Previous by thread: Re: Remote Kernel does nothing
  • Next by thread: Re: Re: Re: Remote Kernel does nothing