Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Compatibility woes

  • To: mathgroup at smc.vnet.net
  • Subject: [mg76190] Re: Compatibility woes
  • From: Mark Adler <madler at alumni.caltech.edu>
  • Date: Thu, 17 May 2007 06:09:01 -0400 (EDT)
  • References: <f2btsp$iha$1@smc.vnet.net><f2em96$2pm$1@smc.vnet.net>

On May 16, 3:26 am, Mark Adler <mad... at alumni.caltech.edu> wrote:
> I doubt that I have plumbed the depths of the
> incompatibilities, since the rate of discovery is not decreasing.

In this case, I hate being right.  The latest 5.2 to 6.0
incompatibility showed up in FindRoot[].  A relatively complicated
function used in a FindRoot[] worked just dandy in 5.2, but now in 6.0
I get complaints due to how and when the function is executed.  Trying
Release[] or Hold[] around the function results in exactly the same
errors.  Providing two starting points to avoid computing a Jacobian
also results in no change.  The function itself works fine when
executed on its own.  Putting it in a FindRoot[] is what exposes the
errors.  Example errors are below.

I am spending much more time than I like trying to get things to work
again that worked just fine before upgrading.  So far, this one is
turning out to be one of the tougher nuts to crack.

Mark


NDSolve::ndinnt: Initial condition 0.0174533 x is not a number or a
    rectangular array of numbers. >>

ReplaceAll::reps: {<<1>>} is neither a list of replacement rules nor
    a valid dispatch table, and so cannot be used for replacing. >>

Set::shape: Lists {vf,\[Gamma]f,sf,hf} and {v,\[Gamma],s,h}<<2>>{v^
    \[Prime][t]=={{-4.28284*10^13 Power[<<2>>] Sin[<<1>>]+0.000709677
    <<2>> <<21>>[<<5>>][<<1>>],<<1>>-<<1>>},<<1>>},<<6>>,<<1>>} are
not
    the same shape. >>



  • Prev by Date: v.6 Editing Stylesheets
  • Next by Date: Re: Fit
  • Previous by thread: Re: Re: Compatibility woes
  • Next by thread: Re: Compatibility woes