Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

DatabaseLink behaviour change in 6.0

  • To: mathgroup at smc.vnet.net
  • Subject: [mg81312] DatabaseLink behaviour change in 6.0
  • From: Yves Klett <yves.klett at googlemail.com>
  • Date: Wed, 19 Sep 2007 05:21:51 -0400 (EDT)

Dear group,

I have some databaselink code (together with an ms access db)that worked fine in 5.2, but does not in 6.0.0

Connecting works as previously:

conn = OpenSQLConnection[JDBC["odbc", "FW_Test"]]

Other jdbc connection types like "Microsoft Access(ODBC)" result in errors like:
JDBC::error: [Microsoft][ODBC Microsoft Access Driver]Allgemeiner Fehler Registrierungsschlüssel 'Temporary (volatile) Jet DSN for process 0x1118 Thread 0x1614 DBC 0x172135a4 Jet' kann nicht geöffnet werden. >>

I get a connection as before, but the SQL queries will not accept Integer or Real arguments as before. In 5.2, the following query worked:

SQLSelect[conn, "tbl_gdata", SQLColumn["Geo_ID"] < 186]

Now, in 6.0, I get

JDBC::error: ""[Microsoft][ODBC Microsoft Access Driver]Optionales Feature wurde nicht implementiert"
(in English something like: "Optional feature not implemented", my environment is German)

The following query with a string as argument works:

SQLSelect[conn, "tbl_gdata", SQLColumn["Geo_ID"] < "186"]

The same occurs wit SQLInsert. In 5.2, I can SQLInsert different types of arguments into my .mdb, while in 6.0 only strings are accepted. Curiously, reading *from* the db works just fine, with numbers, strings etc., only writing works only with string. I noticed that the java environment in 6.0 changed from 1.4 to 2.0, so perhaps there is some catch there.

This of course is not a desirable state of affairs (because I just switched all the infrastructure to 6.0 and would prefer not to have to go back there), so I hope some of you in the know will be able to help me. Any input is appreciated.

Regards,
Yves


  • Prev by Date: Re: Re: plotmarkers in Listplot
  • Next by Date: Re: Can an arrow be drawn on a 3D plot?
  • Previous by thread: Re: confusion about Mathematica Print, Messages,
  • Next by thread: Re: Export to flash error. Export["file.swf",var] Export::rasterr: An unrecoverable error was encountered when rasterizing. >>