Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

Mathematica 6.02 Frontend problems under openSuSE 10.3

  • To: mathgroup at smc.vnet.net
  • Subject: [mg86607] Mathematica 6.02 Frontend problems under openSuSE 10.3
  • From: Achim Mildenberger <admin at fph.physik.uni-karlsruhe.de>
  • Date: Sat, 15 Mar 2008 03:08:08 -0500 (EST)

Hi everyone,

I'm having problems running the Mathematica-FrontEnd 6.02 under openSuSE 10.3.
The kernel (in text mode) is working.
When I start up mathematica, there appears a message

" An error has occurred while Mathematica was starting up.
Mathematica may not function properly until this problem is resolved.
You may choose to continue anyway, but you could encounter additional
problem. "

I'm only offered a "Quit" button, there is no other button in this popup
window.

I think I can definitely rule out font / fontpath problems, the font path
is set up properly.

I found a crude workaround:
Remnoving the mathematica-provided shared Qt libraries
(32 bit): rm SystemFiles/Libraries/Linux/libQt*
(64 bit): rm SystemFiles/Libraries/Linux-x86-64/libQt*
After this, everything seems to be working. 

Can there be a conflict between the libQt that mathematica
provides and the various libs (e.g. X11) that come with
openSuSE 10.3?

Would be nice if someone could shed some light on this?

Best regards,
Achim

PS: The same problem has been discussed in the thread followin
http://forums.wolfram.com/mathgroup/archive/2007/Oct/msg00632.html
but with no final answer as far as I can see.


-- 
Dr. Achim Mildenberger
IT-Admin, Fak. Physik, Uni Karlsruhe
Mail: admin at fph.uka.de
Tel.: ++49 721 608 3578
Fax.: ++49 721 608 9016


  • Prev by Date: Re: Re: Re: Should I uninstall the old version before upgrading?
  • Next by Date: Re: Increasing RandomInteger speed
  • Previous by thread: Re: RealOnly
  • Next by thread: Operate on Heads