Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: RegionPlot3d under sampling plot points?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg99461] Re: [mg99412] RegionPlot3d under sampling plot points?
  • From: Bob Hanlon <hanlonr at cox.net>
  • Date: Wed, 6 May 2009 05:23:56 -0400 (EDT)
  • Reply-to: hanlonr at cox.net

FullSimplify[Reduce[
  {2 x (y - 1) <= 5/2 z + 2 (y - 1) z, z <= x, x >= 1, y >= 2, 
   z >= 1}],
 {z <= x, x >= 1, y >= 2, z >= 1}]

x == z || (z < x < (9*z)/4 && (5*x)/(z - x) + 4*y + 1 <= 0) || (4*x == 
    9*z && y == 2)

Show[
 Plot3D[x, {x, 1, 864000}, {y, 2, 500},
  PlotStyle -> LightBlue],
 RegionPlot3D[(z < x < (9*z)/4 && 
       (5*x)/(z - x) + 4*y + 1 <= 0),
  {x, 1, 864000}, {y, 2, 500}, {z, 1, 864000},
  PlotStyle -> Lighter[Green]],
 ParametricPlot3D[{x, 2, 4 x/9}, {x, 1, 864000},
  PlotStyle -> {AbsoluteThickness[3], Red}]]


Bob Hanlon

---- gramathon <ermyasteshome at gmail.com> wrote: 

=============
Hi All,
I am new to Mathematica, so apologies ahead of time if this is a silly
problem. I am trying to use RegionPlot3D to plot the following,
RegionPlot3D[
 2 x(y - 1) <= 2.5  z+ 2 (y - 1)  z&& z<= x, {x, 1,
  864000}, {y, 2, 500}, {z, 1, 864000}, PlotStyle -> Orange,PlotPoints-
>100]

The problem is I end up getting gaps in regions where I expect none to
exist.
- I tried increasing the PlotPoints.Though that reduces the number of
gaps at first (partly removes the gaps for the higher values of NA and
NP but gaps remain, in the lower values of the two axises) after a
certain number of point >= PlotPoints -> 150the graph ends up looking
completely different with Spikes everywhere and still has gaps which
does not make sense....(I am not sure if this could be due to the
graphics card because the above code is relatively smoother on my less
powerful machine but still has gaps)
- I tried providing different plotpoints to different axises E.g.
PlotPoints-> {111,100,111}... but that did not seem to help either.
- I tried MaxRecursion as well but that does not seem to help in this
case either...
I am completely lost, and have been spending quite a bit of time
trying to search for an answer...WOULD REALLY APPRECIATE it if anyone
could Help
Thanks a bunch GUYS
Version  7 of Mathematica




  • Prev by Date: Re: RegionPlot3d under sampling plot points?
  • Next by Date: Re: Some function like Position[] but uses criteria, not pattern?
  • Previous by thread: Re: RegionPlot3d under sampling plot points?
  • Next by thread: "Sticky" options when using Plot[] -- bug or feature?