Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: remote kernel trouble

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104655] Re: remote kernel trouble
  • From: Ian <carroll.ian at gmail.com>
  • Date: Fri, 6 Nov 2009 05:15:01 -0500 (EST)
  • References: <hcu5jr$m9d$1@smc.vnet.net>

Thanks to help from bj...@mit, but I'm still not there. I'm now
getting a msg "The kernel cruncher failed to connect to the front end.
(Error = MLECONNECT). You should try running the kernel connection
outside the front end." I tried, but what sort of behavior is good or
bad?

My configuration on a Windows Vista machine running Mathematica 7.0 is

Arguments to MLOpen:
-LinkMode Listen -LinkProtocol TCPIP -LinkOptions MLDontInteract

Shell command to launch kernel:
plink -i keyfile carroll@cruncher -x math -mathlink -linkmode Connect -
linkprotocol TCPIP -linkname "`linkname`" -linkhost `ipaddress`

When I run exactly this from cmd line in Vista, I get
> bash: linkname: command not found
> bash: ipaddress: command not found

> LinkOpen::linke: --Message text not found -- (MathLink linkname missing or malformed.)

When from the cmd line in Vista I run
plink -i keyfile carroll@cruncher -x math -mathlink -linkmode Connect -
linkprotocol TCPIP -linkname 5301 at local.machine

there's no message, and I have to ctrl-C to get back to the cmd
prompt. a MathKernel does start on cruncher. should something else
happen?

thanks for any help!
-Ian



On Nov 5, 1:24 am, Ian <carroll.... at gmail.com> wrote:
> I have followed the very simple instructions for setting up a remote
> kernel in Mathematica 7.0 on Windows Vista, but my connection is not
> working. I believe the source of the problem is the location of the
> ssh keys. After telling a notebook to start the remote kernel, I get
> to a dialog which says:
>
> "C:\Users\Ian\.ssh\known hosts does not exist Are you sure you want to
> create it?"
>
>  My username is "carroll" not "Ian", and Mathematica knows this:
>
>  In = $UserName
> Out = carroll
>
> "carroll" is also my username on the remote machine. How do I force
> Mathematica to create and look for the known_hosts file in "C:\Users
> \carroll\.ssh\"?
>
> And yes, even if I let the known_hosts file get created in Users\Ian
> \.ssh, the connection still does not work.
>
> Thanks
> -Ian



  • Prev by Date: Re: ForAll testing equality, and Limit evaluating wrong
  • Next by Date: Re: Re: what's wrong with these expressions?
  • Previous by thread: Re: remote kernel trouble
  • Next by thread: Re: Re: remote kernel trouble