Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Connecting to remote kernel

  • To: mathgroup at smc.vnet.net
  • Subject: [mg111782] Re: Connecting to remote kernel
  • From: Anne <annie.goj at gmail.com>
  • Date: Fri, 13 Aug 2010 06:55:13 -0400 (EDT)
  • References: <i3to4r$sfg$1@smc.vnet.net>

Hi,
Sadly no suggestions here.  I am having the same problem setting up a
remote kernel with Linux (on both the local and remote machines.)
Searching online I have seen several other similar posts (for example
this thread http://groups.google.com/group/comp.soft-sys.math.mathematica/browse_thread/thread/2a7cc4680bd489aa#
), but no solution yet.

I have tried basic configuration options, with the machine address set
as mymachine.edu and my user name which is the same on the host and
remote machines.  I have tried editing the kernel configuration to
give the path of the program on the remote machine:
KernelProgram: /usr/local/bin/math
or
KernelProgram:/usr/local/bin/MathKernel
ssh works between my local machine and the remote machine with an rsa
key and passphrase.  When I start the remote kernel from the local
frontend, I am prompted for my passphrase, and a "top' command of the
processes on the remote machine shows a new sshd process which dies
immediately.  My local machine gets an error of:
The kernel linuxkernel failed to connect to the front end. (Error MLECONNECT). You should try running the kernel connection outside the
front end.
I think someone else in my office was able to run a remote kernel on
this same linux machine from a mac, so I suspect that the
configuration problem is on the local end.

-AG


On Aug 11, 3:48 am, Jim Lambaugh <lamba... at gmail.com> wrote:
> Hi
>
> I wish to connect to a remote kernel running Mathematica. I have given
> the information in  "Basic Options" when adding a new Remote Kernel,
> and when I start a calculation such as "Print["test"]" I am asked to
> connect via SSH, which succeeds. After that it says:
>
> The kernel Remote_Math failed to connect to the front end. (Error MLECONNECT). You should try running the kernel connection outside the
> front end.
>
> Do you have any suggestions? The video at the Mathematica website does
> not tell me anything I don't already know. The remote kernel is
> running Linux (Redhat I think).
>
> Best,
> Jim.



  • Prev by Date: Re: Problem with renaming Mathematica path on Mac OS X
  • Next by Date: Re: Custom dialog during evaluation
  • Previous by thread: Re: Connecting to remote kernel
  • Next by thread: Re: Connecting to remote kernel