Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Connecting to remote kernel

  • To: mathgroup at smc.vnet.net
  • Subject: [mg111882] Re: Connecting to remote kernel
  • From: Anne <annie.goj at gmail.com>
  • Date: Tue, 17 Aug 2010 01:20:12 -0400 (EDT)
  • References: <i3to4r$sfg$1@smc.vnet.net> <i438c5$hlo$1@smc.vnet.net> <i45rau$g2e$1@smc.vnet.net>

Yes, Bob helped me sort out my Kernel Configuration problems as
well :>
It now works with the Shell Command to launch the Kernel:

`java` -jar `mathssh` myusername at myremotemachine.edu /usr/local/bin/
MathKernel -mathlink -LinkMode Connect -LinkProtocol TCPIP -LinkName
"`linkname`" -LinkHost "129.7.xx.xxx"


On Aug 14, 5:31 am, Cristobal Navarro <axisch... at gmail.com> wrote:

> Anne and Jim
>
> we and Bob after days of trial and error discovered the problem. The
> problem of linux frontends is that in somecases the frontend
> interprets badly the argument 'ipaddres' from the remote kernel
> advanced options.
>
> from a terminal do ifconfig and copy your IP (for example
> 172.16.21.64)
> then go to your remote kernel advanced options and look for the
> parameter -LinkHost `ipaddres` and replace 'ipadress' with your real
> IP, in my case it looks like this now -LinkHost 172.16.21.64
>
> then launch a command with the remote kernel chosen and it should work
> try $MachineName command
> i hope this works for both of you!
>
> All credits to Bob really!



  • Prev by Date: Re: 2 issues with Mathematica-data handling
  • Next by Date: How can I totalize by month, by year?
  • Previous by thread: Re: Connecting to remote kernel
  • Next by thread: Frontend option settings