Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2011

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Preventing In-line Math Typesetting From Being Scaled Down in Text

  • To: mathgroup at smc.vnet.net
  • Subject: [mg120603] Re: Preventing In-line Math Typesetting From Being Scaled Down in Text
  • From: blamm64 <blamm64 at charter.net>
  • Date: Sat, 30 Jul 2011 06:03:25 -0400 (EDT)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • References: <j0oog9$kpr$1@smc.vnet.net>

On Jul 27, 6:15 am, John Fultz <jfu... at wolfram.com> wrote:
> Looks like there's a minor bug in the updating mechanism.  Perhaps this is what you ran into.  If, after following my procedure, you save, close, and reopen the notebook, you'll see that the change has taken effect.
>
> Core.nb is inside the Mathematica layout, but it's generally not a good idea to be changing things there.  If you're hoping to make the change globally for all notebooks on your system, let me know and I can walk you through that procedure.  However, doing so will not change the notebook when viewed on somebody else's system, where as the Format->Edit Stylesheet... change will persist with the notebook regardless of which system it's viewed on.
>
> Sincerely,
>
> John Fultz
> jfu... at wolfram.com
> User Interface Group
> Wolfram Research, Inc.
>
>
>
> On Tue, 26 Jul 2011 14:10:44 -0400, Gregory Lypny wrote:
> > Hello Mr. Fultz,
>
> > Tried but it didn't work.  I executed the command in the stylesheet
> > notebook corresponding to the notebook I'm working with.  Perhaps I've
> > misunderstood.  Also, not sure where to find Core.nb.  Is it in the
> > application package?
>
> > Gregory Lypny
>
> >> On Fri, 22 Jul 2011 19:46:07 -0400 (EDT), Gregory Lypny wrote:
> >>> Hi everyone,
>
> >>> When I include fractions as inline math typesetting, they are scaled
> >>> down
> >>> to fit the effective line height of the cell. How can I prevent this
> >>> or,
> >>> I guess, make the line height automatically expand to accommodate the
> >>> math? If my regular text in the cell is 12-point times, I'd like all
> >>> math variables that are not subscripts or superscripts to be 12-point
> >>> as
> >>> well.
>
> >>> Incidentally, other big typeset objects like matrices are not scaled
> >>> down, or at least they down't appear to be.
>
> >>> Sincerely,
>
> >>> Gregory
>
> >> If you look in Core.nb, you'll find a style called "InlineCell". This
> >> style is
> >> automatically applied to all inline cells everywhere. One of the
> >> options it has
> >> set is:
>
> >> ScriptLevel->1
>
> >> This is what's causing the behavior you're seeing. You can override
> >> this with a
> >> custom stylesheet. For example, in a given notebook, you can make a
> >> private
> >> override by doing Format->Edit Stylesheet..., and pasting and
> >> interpreting the
> >> following cell expression at the end of the resulting stylesheet
> >> notebook:
>
> >> Cell[StyleData["InlineCell"], ScriptLevel->0]
>
> >> Sincerely,
>
> >> John Fultz
> >> jfu... at wolfram.com
> >> User Interface Group
> >> Wolfram Research, Inc.- Hide quoted text -
>
> - Show quoted text -

Thanks John!  Is there anything similar for Input cells
(StandardForm)?  Often, I prefer to enter math Input in 2D, and if I
enter a 2D Piecewise, and one or more lines of the Piecewise have
fractions and/or square roots, the font ends up being really tiny (for
me).  So some similar setting for Input (StandardForm) to force the
font size to be the same regardless of position would be helpful to
me.

-Brian L.




  • Prev by Date: Re: FinancialData errors
  • Next by Date: Re: FinancialData errors
  • Previous by thread: Re: Preventing In-line Math Typesetting From Being Scaled Down in Text
  • Next by thread: Re: Preventing In-line Math Typesetting From Being Scaled Down in Text