MathGroup Archive 1990

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re:Plot problem

  • To: uiucuxc!!mathgroup
  • Subject: Re:Plot problem
  • From: uiucuxc!kinghorn.chem.WSU.EDU!don (Don Kinghorn)
  • Date: Fri, 22 Jun 90 12:44:27 PDT

>  We have some NeXT machines in the department and we have run into a difficulty
>with Plot.   Try this on your NeXT if you have one available (the problem
>does not seem to occur on our MIPS)
>In[1]:=  f[x_]:= x^(5/3) + 5 x^(2/3);
>             g=D[f[x],x]
>In[2]:= Plot[{f[x],g}, {x, -5, 3}]
>In[3]:=  Show[%,AspectRatio->Automatic]
>The machine takes an awful long time to compute this and equally long times
>to copy and paste someplace else (if you can get it to that at all).   Worse,
>the window server seems to lock up so you can't do anything until this compute
>is done!   What's the problem here?   When we run this on our MIPS using
>X-windows graphics (the machines seem about equal in speed on other
>mathematica stuff) the result comes up FAST!   Help!   We would like to use
>some NeXT's in a calculus lab this fall where no doubt problems like this
>will come up again.....   When the machine does finally produce the graphic,
>just try to PRINT  IT!   Yikes!   Your machine dies!

I ran your input statements on a minimally configured NeXT running the 1.0
 system software and got the following results with ShowTime on.

f[x_]:= x^(5/3) + 5 x^(2/3);
0.0166667 Second

Plot[{f[x],g}, {x, -5, 3}]
2.28333 Second

0.483333 Second

The results seem fine on my machine. Copy and paste into WriteNow worked fine
as did printing from the Mathematica window .
You didn't say how your NeXT was configured, but if you're running 1.0 with the
40 meg swap drive your swap file may be growing to large. I've had this problem on 

my machine with the result being symptoms like you described above. System 1.0
does not clean up the swapfile correctly.You can run df from a UNIX prompt to 

check this out. The easiest work around I know is to power down when the swapdisk
is greater than 75% full. The latest upgrade, 1.0a, fixes this problem (I hope) 

I'm waiting on the upgrade myself.

---Don Kinghorn

  • Prev by Date: Re: Remote kernels in Mathematica
  • Next by Date: mathlink.c bug
  • Previous by thread: Two column printing
  • Next by thread: mathlink.c bug