Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1998
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: greek letters in .ps plots


  • To: mathgroup@smc.vnet.net
  • Subject: [mg11099] Re: greek letters in .ps plots
  • From: "P.J. Hinton" <paulh@wolfram.com>
  • Date: Sun, 22 Feb 1998 14:55:25 -0500
  • Organization: Wolfram Research, Inc.
  • References: <6cgbgv$s1t@smc.vnet.net>

On 18 Feb 1998, Ari Buchalter wrote:

> Hi. I'm trying to create postscript plots of mathematica graphics, using
> the following commands:
> 
> First type in 
> 
> PSFile[gr_,fn_String]:=Display["!" <> $TopDirectory <> "/SystemFiles/
>  Graphics/SystemResources/psfix > " <> fn,gr]
> 
> Then create your graphics object, call it g:
> 
> g=Show[heap of stuff]  (NOTE: might want the option
> DisplayFunction->Identity)
> 
> Then type the command 
> 
> PSFile[g,"stuff.ps"]
> 
> 
> This generates a postscript file, but my PROBLEM is this:
> 
> There are greek letters in the plot, generated using the Text command,
> but these show up as normal letters in the postscript picture, even
> though they appear as Greek symbols on the mathematica screen.

First of all, you need to clarify what you mean by "show up."  

Are you attempting to print the EPS file on a PostScript printer?  If
so, then you will need to make sure that the Mathematica-specific font
from which the Greek letters come (no, the Symbol font is not used) is
resident in your printer's memory when you attempt to print the file. 
There is a comprehensive list of FAQ entries for this at the Technical
Support website: 

http://www.wolfram.com/support/Systems/All/ManualFontDownload.html

If you are attempting to view the PostScript using an onscreen previewer
that acts as a front end to Ghostscript, then you will need to edit the
Ghostscript Fontmap file as per the instructions at URL:

http://www.wolfram.com/support/Graphics/Formats/EPS/Ghostscript.html

--
P.J. Hinton
Mathematica Programming Group           paulh@wolfram.com Wolfram
Research, Inc.                  http://www.wolfram.com/~paulh/




  • Prev by Date: Re: Overloading Integrate
  • Next by Date: Re: typesetting problem in Mathematica3 / NT
  • Prev by thread: greek letters in .ps plots
  • Next by thread: Overloading Integrate