Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1998
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Erroneous ImageSize?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg13443] Re: Erroneous ImageSize?
  • From: paulh (P.J. Hinton)
  • Date: Fri, 24 Jul 1998 01:45:31 -0400
  • Organization: Wolfram Research, Inc.
  • References: <6p6qor$5jb@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

In article <6p6qor$5jb at smc.vnet.net>, siegman at ee.stanford.edu (AES)
writes:

|> I'm Showing a couple of different GraphicsArrays of plots and trying
to |> magnify their size, on screen and especially on printout, using
|> 
|>    Show[GraphicsArray[{---}], ImageSize->{432,180}] |> 
|> Increasing the numerical parameters in the ImageSize option
definitely |> increases the size of the figures; but 432 points --
which should be 6 |> inches, right? -- only gives me a *5 inch* wide
plot, both on the |> screen and on the paper.
|> 
|> That is, on screen, with Ruler and Show Page Breaks turned ON, if I
|> click on one of the figures the bounding box for the plot is only 5
|> inches wide, according to the Ruler.   |> 
|> And on the paper the actual printed figures are also smaller than 5"
|> wide by about the amount of margin between the bounding box and the
|> actual plots.
|> 
|> Using just ImageSize->432 gives me a square bounding box, 5" both
ways; |> but since the GraphicsArrays have an overall aspect ratio more
like |> 1/3, the 180 vertical should give plenty of margin around them,
top and |> bottom.
|> 
|> I don't knowingly have any magnifications or demagnifications turned
on, |> for the screen display or in the Page Setup or Print dialog
boxes; they |> all say 100%.  All the Magnification parameters in the
Option Inspector |> for the Notebook are set to 1.

You may have all of your magnification parameters set to 100 %, but  in
all reality, the thing that is making your life difficult is nowhere to
be found in either Cell or notebook Options.  Do the following:

1) With your problematic notebook selected, click on the front end  menu
command sequence:

	Format -> Edit Style Sheet...

2) Click on "Import Private Copy" when a dialog box pops up.

3) Open the cell groups 

	Styles for Input/Output

	Graphics

4) Unformat the cell prototype for

	Graphics/Printout

You'll see this setting:

	Magnification->0.8

This is what's causing your discrepancy.  This style sheet setting  is
inherited by all Graphics cells when the Printout environment is used.

When you size your graphics, they get reduced by 20 % when printed. If
you want them to appear as 100 %, change the magnification value to
1.0, and you should see a good matchup.

--
P.J. Hinton	
Mathematica Programming Group		paulh at wolfram.com Wolfram Research,
Inc.			http://www.wolfram.com/~paulh/ Disclaimer: Opinions expressed
herein are those of the author alone.


  • Prev by Date: Re: EPS save
  • Next by Date: Re: Re: Is this a bug?
  • Previous by thread: Erroneous ImageSize?
  • Next by thread: Re: Is this a bug?