Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2000
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2000

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: ListPlot bug


The first problem raised by Christopher Tong needs some example for me to
understand it.

Now, Timothy Stiles give us an example. I have an old Mac G3 (first ones) and an
old Epson stylus color 600 and I 'm running the 4.0 release of Mathematica. I
tried the code of Tim. I could see 5 points, as expected, no less, no more. The
axes starts at {1,1}, so the first point is at the cross of the axis. It is
difficult to see it with the default size. Is that the top that Tim and
Christopher are speaking about?

The printer gives the same thing: 5 points.

When increasing the size, then the first point shows well at the cross of the
axis. No more point when printing. Always 5 points.

To set things so that that none of the points go on axis it is possible to use
PlotRange as follows:

Show[ListPlot[data, PlotStyle -> AbsolutePointSize[5],
    PlotRange -> {{-1, 10}, {-1, 10}}]]

Mind the way you are using PlotRange. If you set it like  PlotRange->{0,10}, it
means that the y -axis will run from 0 to 10. See "Help Browser > PlotRange". If
you want to give values both to x-axis and y-axis, you should put the right
structure for PlotRange, I mean: {{xmin, xmax}, {ymin, ymax}}

I hope that I understood well the question. But may be my old printer can't follow
the game? May be new material and PC are more inventive?

Jacqueline Zizi

-----------------------------------------------------------------------------------------------------

Timothy Stiles wrote:

> I've seen this same problem with my computer. I use a Windows 98
> computer and print with an HP Laser Jet 5si. The point does not appear
> on the screen only when printed. That is, I was able to reproduce this
> problem with the following inputs
>
> data={1,4,6,3,5}
>
> ListPlot[data]
>
> produces a fine picture but
>
> ListPlot[data, PlotStyle->AbsolutePointSize[5]]
>
> produces a graphic that in addition to the data points has a extra point
> at the top of the y-axis. I tried removing it by first increasing the
> PlotRange and then using Show to decrease it
>
> Show[ListPlot[data,
> PlotStyle->AbsolutePointSize[5],PlotRange->{0,10}],PlotRange->All]
>
> but the final graph still has the extra point on the y-axis when
> printed. The only way I've been able to not get the extra point when
> printing is to use
>
> Show[Graphics[{AbsolutePointSize[5],Point[data1],Point[data2],...}],Axes->True]
>
> Has anyone else seen this problem and/or have a better solution to it?
>
> -- Tim Stiles
>
> Christopher Tong wrote:
>
> > Has anyone else encountered a bug when printing a file containing
> > a ListPlot graphic (where the PointSize is not the default, but
> > set in the ListPlot command)?
> >
> > The bug is that a spurious point is plotted
> > at the top end of the y-axis.  Not all of my ListPlot graphics
> > have this spurious point, but the ones that do have it always have
> > it (every time I print).  The spurious point does not show up on
> > the screen.
> >
> > Any ideas on the cause and how to remedy it?  Thanks!
> > I can send example code to anyone who is interested.
> >
> > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > CHRISTOPHER TONG                    Graduate research assistant
> > Dept. of Physics
> > Purdue University                   Office:  PHYS-B20
> > 1396 PHYS Building                  Office phone:  (765) 494-0407
> > West Lafayette, IN  47907-1396      Email:  ctong at purdue.edu
> > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



  • References:
  • Prev by Date: RE: Rotation of 2D graphics
  • Next by Date: Re: Question: nonlinear differential equation with boundary conditions
  • Previous by thread: Re: ListPlot bug
  • Next by thread: Re: Getting coordinates of array member