MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: need help with CUDA setup on my MacBook Pro

  • To: mathgroup at
  • Subject: [mg114835] Re: need help with CUDA setup on my MacBook Pro
  • From: Patrick Scheibe <pscheibe at>
  • Date: Sun, 19 Dec 2010 05:10:17 -0500 (EST)


did you try to compile and start the examples which come with CUDA?
Which version of the CUDA Toolkit do you use? If you're using 3.2,
please use 3.1. 


On Fri, 2010-12-17 at 23:48 -0500, Stefan Wolfrum wrote:
> Hi all,
> my MacBook Pro (MBP) is running OS X 10.6.5 and Mathematica Home
> Edition (32bit).
> It's a MBP with two graphics chips: an Nvidia GeForce 9400M and a 9600M
> GT -- the latter one is listed as a support chipset for Mathematica's
> CUDA functionality. I activated the 9600M GT chip and verified that
> it's the currently used one.
> I, too, downloaded and installed Nvidia's CUDA driver.
> However, I still get "False" from the CUDAQ[] query.
> I thought that's because of the missing CUDA Ressources so I tried
> In[17]:= CUDAResourcesInstall[]
> but I immediately got
> Out[17]= $Failed
> Mathematica never even tried to download that from it's paclet server
> -- despite the fact that I allowed Mathematica to access the Internet
> in the settings.
> So I downloaded the paclet manually (which worked).
> However, on a Mac, the downloaded file ends in .zip:
> Now I tried several different variations of the path to this paclet in
> the CUDAResourcesInstall command:
> - gave it the full path including the zip filename
> - unpacked the zip file, got a folder "CUDAResources-OSX-"
> (without the ".paclet"), and used the path to this folder
> - just removed the ".zip" suffix from the downloaded file and gave
> CUDAResources-OSX- as parameter
> .... but none worked. :-(
> The "best" I got (with the last variation mentioned above) was this:
> In[14]:=
> CUDAResourcesInstall["/Users/stefan/Downloads/CUDAResources-OSX-
> aclet"]=E2=80=A8
>              Message::name :  "Message name "CUDAResources paclet path
> `1` is not valid." is not of the form symbol::name or
> symbol::name::language.
> Out[14]= $Failed
> Any help on how I can install this paclet?
> And why doesn't the normal (automatic) installation via
> CUDAResourcesInstall[] work???
> Thanks a lot!
> Stefan.

  • Prev by Date: Re: Integral of Associated Legendre polynomial
  • Next by Date: Re: NMinimize::nrnum:
  • Previous by thread: need help with CUDA setup on my MacBook Pro
  • Next by thread: Re: need help with CUDA setup on my MacBook Pro