MathGroup Archive 2012

[Date Index] [Thread Index] [Author Index]

Search the Archive

OutputResponse issue

  • To: mathgroup at
  • Subject: [mg128884] OutputResponse issue
  • From: Eduardo M. A. M. Mendes <emammendes at>
  • Date: Sun, 2 Dec 2012 04:58:40 -0500 (EST)
  • Delivered-to:
  • Delivered-to:
  • Delivered-to:
  • Delivered-to:


Can anyone help me with the following issue?

Plot[Chop at OutputResponse[TransferFunctionModel[0.53/(0.53+2 s+3 s s+s s s),s],UnitStep[t],t],{t,0,10}]

which returns

OutputResponse::nsymb :  "0.0002042857142857143` must be a symbol. \
Appearance->{Automatic, None},

and several other msgs.

I have tried a different approach

restfmf[t_,k_]:=OutputResponse[TransferFunctionModel[(k 1.06)/(k 1.06+2 s+3 s s+s s s),s],UnitStep[t],t];

Plot[Chop@Evaluate@restfmf[t, 0.5], {t, 0, 10}]

but got the same error messages

What am I missing here?

Many thanks


  • Prev by Date: M8 parallel to M9 installation
  • Next by Date: Find all roots of an interpolating function (solution of a
  • Previous by thread: Re: M8 parallel to M9 installation
  • Next by thread: Re: OutputResponse issue