Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Re: Re: Remote Kernel does nothing


On Feb 5, 2007, at 7:28 AM, T.Sariyski wrote:

> I still get the same "Low-level MathLink error":
>
> Mathematica could not establish a connection to the kernel.
> Kernel: craft99.
> Low-level MathLink error: The linkname was missing or not in the  
> proper form.
>
> Here are the Kernel Configuration Options:
>
> Advanced Options:
> -LinkMode Listen -LinkProtocol TCPIP -LinkOptions MLDontInteract   - 
> LinkName "3500"  -LinkHost 192.168.187.99
>
> Shell command to launch kernel:
> ssh  tsariysk at 192.168.187.99  ' "math" -mathlink -LinkMode Connect - 
> LinkProtocol TCPIP -LinkName "3500"  -LinkHost 192.168.187.99'
>
> I did make sure that SSH_AUTH_SOCK environmental variable is  
> visible for both windows and cygwin:  I ssh   
> tsariysk at 192.168.187.99 without password from Windows Command  
> Prompt as well as from Cygwin shell. I expect that Mathematica also  
> acknowledges of SSH_AUTH_SOCK but I do not know how to verify it.  
> Is there a debug mode for MathLink or other tools that make  
> troubleshooting more transparent?
> Thanks, Ted


Lets try a couple of more options.  First, change the Advance Options  
to:

-LinkMode Listen -LinkProtocol TCPIP -LinkHost 192.168.187.99

This change will allow the OS to determine the port number used for  
the link.  In addition, MathLink will display a dialog box that tells  
you the name of the link that it created.  Write that name down.

Change the shell command to:

ssh tsariysk at 192.168.187.99 math -mathlink -LinkMode Connect - 
LinkProtocol TCPIP -LinkName `linkname`

Now when you start the Kernel, log in to 192.168.187.99 in another  
terminal window.   From the command line run:

ps axwww | grep MathKernel

( the arguments to ps may be different depending on your flavor or  
Unix.)

Verify that the -LinkName command line argument to MathKernel is  
actually the same value as the value you gathered from the dialog box.

Send me what you find out.


Steve



  • Prev by Date: Re: NIntegrate - problems with HoldAll property(?) - not quite a
  • Next by Date: Re: NIntegrate - problems with HoldAll property(?) - still not a
  • Previous by thread: Re: Re: Re: Re: Remote Kernel
  • Next by thread: Re: Re: Re: Re: Remote Kernel does nothing