Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Re: Re: Remote Kernel does nothing

  • To: mathgroup at smc.vnet.net
  • Subject: [mg73180] Re: [mg73139] Re: [mg73110] Re: [mg73075] Re: [mg73026] Remote Kernel does nothing
  • From: Steve Wilson <stevew at wolfram.com>
  • Date: Tue, 6 Feb 2007 03:43:08 -0500 (EST)
  • References: <200701301124.GAA12853@smc.vnet.net> <200702010831.DAA10807@smc.vnet.net> <200702030948.EAA06211@smc.vnet.net> <200702041241.HAA17801@smc.vnet.net> <45C73F01.6040702@craft-tech.com> <24FB34A9-E0F5-403D-882C-7A656E0FF521@wolfram.com> <45C76D40.3020908@craft-tech.com> <A53F95B4-93B7-40B6-B32A-088691162641@wolfram.com> <45C794E1.4030607@craft-tech.com>

On Feb 5, 2007, at 1:34 PM, T.Sariyski wrote:

> I have a wireless (disabled) and an ethernet port. I don't get any  
> dialog box except "Low-level MathLink error: Unknown internal  
> error. ". To avoid a silly mistake from my side here is what I do:
> 1. On Kernel Configuration Options I set:
> MLOpen:            -LinkMode Listen -LinkProtocol TCPIP -LinkHost  
> 192.168.187.99
> Shell command:    ssh tsariysk at 192.168.187.99 math -mathlink - 
> LinkMode Connect -LinkProtocol TCPIP -LinkName `linkname`
>

> Ethernet adapter Local Area Connection:
>
>        Connection-specific DNS Suffix  . : craft-tech.com
>        Description . . . . . . . . . . . : Broadcom 440x 10/100  
> Integrated Controller
>        Physical Address. . . . . . . . . : 00-0D-56-EA-59-98
>        Dhcp Enabled. . . . . . . . . . . : Yes
>        Autoconfiguration Enabled . . . . : Yes
>        IP Address. . . . . . . . . . . . : 192.168.187.232
>        Subnet Mask . . . . . . . . . . . : 255.255.255.0
>        Default Gateway . . . . . . . . . : 192.168.187.1
>        DHCP Server . . . . . . . . . . . : 192.168.187.248
>        DNS Servers . . . . . . . . . . . : 192.168.187.150
>                                            192.168.187.20
>        Lease Obtained. . . . . . . . . . : Monday, February 05,  
> 2007 2:38:03 PM
>        Lease Expires . . . . . . . . . . : Monday, February 05,  
> 2007 4:18:03 PM


I see the problem.  I had you using -LinkHost incorrectly.  Change  
the MLOpen line to:

-LinkMode Listen -LinkProtocol TCPIP -LinkOptions MLDontInteract


With the MLOpen arguments, -LinkHost tells MathLink to create a link  
on the listed interface.  192.168.187.99 is not an interface on your  
Windows system.  If you want to use -LinkHost with the MLOpen  
argument, you have to be sure to use an actual ip number (or domain  
name) for an interface on your system (in this case  
192.168.187.232).  When you use the -LinkHost option with the Shell  
command, you are telling the remote process to connect to a link at  
the listed ip number (or domain name).  So in effect the first time  
you ran this set up you were telling the remote Kernel to try and  
connect to a link at its own IP number.  In general -LinkHost should  
not be used unless you have a good reason.  It overrides the default  
ip number or domain name that MathLink generates when it  
automatically creates linknames.  LinkHost is useful when you have  
multiple interfaces on a machine and want MathLink to bind to a  
particular interface without affecting any of the other interfaces.   
LinkHost can also be useful if you have firewalls, routers, or other  
kinds of network devices or setups that cause a bit of trickiness  
with ip numbers between two machines.  If you don't have any of those  
conditions on your network, it is better to leave -LinkHost unused.

One further note.  You can also specify the interface to use by  
giving the interface in the -LinkName option for the MLOpen  
arguments.   Your original example could have been:

MLOpen:

-LinkMode Listen -LinkProtocol TCPIP -LinkName 3500 at 192.168.187.232

Shell Command:

ssh tsariysk at 192.168.187.99 math -mathlink -LinkMode Connect - 
LinkProtocol TCPIP -LinkName `linkname`



I should have seen this at first.  My apologies for taking so long.

Steve



  • Prev by Date: Re: NIntegrate - problems with HoldAll property(?)
  • Next by Date: Point inside polygon
  • Previous by thread: Re: Re: Re: Re: Remote Kernel does nothing
  • Next by thread: Re: Re: How to do quickest